Temperature/humidity sensor for MiSOL weatherstation

Well, the MiSol weatherstation been working form more than two full years without any interruption. But then a problem arose: the humidity readings were getting more and more incorrect and after a short period of time became zero all together. Clearly a sensor was broken.

Finding the sensor was not a difficulty: it had to be in the tiny Stevenson screen below the main body. Unscrewing is easy and after taking the shells apart the sensor is located. It is wrapped in filter paper and glued by some kind of kit.

From the writing on the little PCB one finds that communication is through I2C: two wires for communication. One wire for power and one for ground complete the connection with the main body. The PCB will not be for sale somewhere, I did not even try. But with some help – in my case a stereo microscope – I could read the writings on the chip: SHT 30 DI. A datasheet was quickly found . What is available on the market is an identical model albeit slightly more accurate SHT31DIS. It is readily available on a breakout board.

Mounting the larger PCB was a challenge. First it needed protection against moist and dirt, so a plastic spray was applied … after protecting the little hole in the chip! Next some filter paper needed to be found. That is not so cheap but could be found: 0.1 μm PTFE turned out to be available. Folding it into a nice envelope to hold the PCB and gluing it with silicone kit to the entrance of the Stevenson screen finalized the sensor replacement.

The weather station is now working for a few months with the new sensor without any further problem. The repair cost a bit of money but was fun to do. Buying a new weather station would cost about 5 times the cost. Hence: cost effective as well.

Geef een antwoord

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *